login about faq

Hi, We are running " SSH Tectia Server 6.0.5 on i686-pc-linux-gnu" having problem increasing the ulimit for the jboss user. when the user ssh to box, still ulimit -a is 1024. I have the pam_limits.so added in the /etc/pam.d/ssh-server-g3

/etc/security/limits.conf

jboss soft nofile 65000

jboss hard nofile 65000

The work around is to add the ulimit value in the /etc/ssh2/sshd2_custom_env and /etc/sysconfig/xinetd. Restart the ssh and xinetd daemon.

Any help appreciated.

Thanks.

asked Mar 14 '11 at 09:59

Moorthi%201's gravatar image

Moorthi 1
1111


Is pam-calls-with-commands enabled on the configuration? This needs to be set to yes so that the limit propagates to the user's shell.

See this answer for how to set it.

link

answered Mar 14 '11 at 21:05

Roman's gravatar image

Roman ♦♦
7735817

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

Asked: Mar 14 '11 at 09:59

Seen: 2,261 times

Last updated: Mar 28 '11 at 21:22

Related questions

All user contributed content licensed under the cc-by-sa license.
Powered by OSQA.