login about faq

I have installed SSH Tectia Server on Windows Server 2003.

The problem is have is that the users can see the virtual folder but when they click on it nothing happens, they stay in the same folder. This is with multiple clients but I test it with WinSCP 4.25.

The strange thing is that the administrator account can open this folder. The users can copy files into the virtual folder by dragging a file onto the folder. But are unable to open the folder itself.

The permissions that the users got is full access to the destination folder.

It is a standalone web-server and the users are standard users with only Users as membership. I have tried to make on user an Administrator but this doesn't fix the problem.

I am using the latest version of SSH Tectia Server and Windows Server 2003 R2 is fully up to date.

The server is setup for testing and once we got it working we will buy multiple licences but for now it is a trail version.

I am sure that I forgot some information so please let me know what details I need to give.

My knowledge with SSH server is very small and I hope that you can help me out.

Thanks, Laurens Bot

asked Jan 15 '10 at 10:38

Laurens%20Bot's gravatar image

Laurens Bot
111

edited Sep 21 '11 at 17:12

SSH%20KB's gravatar image

SSH KB ♦
509249246237


Hi Laurens,

This sounds like a permissions problem on the folder on that server. I would recommend double checking the actual permissions on that folder. It might be that it's inheriting permissions from a parent folder and might not be right away obvious.

Have you tried looking at the Advanced page in the security tab for that folder? That should show if there are any inherited permissions. (Any inherited deny permissions would override grant ones that were explicitly given for that folder)

Another thing to try is to create a folder on the root (C:) and see if the problem reproduces in there as well.

I've not seen any problems with 6.1.4 Tectia Server on that platform and can upload files with both Tectia client and WinSCP without problems.

link

answered Jan 15 '10 at 16:10

Roman's gravatar image

Roman ♦♦
7735817

It is not a permission problem as I can upload the file into the virtual folder. The problem is that I cannot open the virtual folder. Upload files into it is no problem. The strange thing is that for one user it works but for the others it simply doesn't let me get into the folder itself.

link

answered Jan 15 '10 at 17:01

Laurens%20Bot%201's gravatar image

Laurens Bot 1
1

This can still be a permissions problem if the permissions of the folder are set so that certain users (non-admins) can write to it, but not list the contents (aka "a blind drop" folder). This can be easily verified by logging in at the console (or remote desktop) with the user in question and trying to write to that same folder.

(Jan 17 '10 at 10:44) Roman ♦♦ Roman's gravatar image
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×6
×5
×1

Asked: Jan 15 '10 at 10:38

Seen: 5,240 times

Last updated: Sep 21 '11 at 17:12

All user contributed content licensed under the cc-by-sa license.
Powered by OSQA.