login about faq

I got this error when trying to list the open connections

./ssh-broker-ctl list-connections
ssh-broker-ctl: Broker connection failed (Unable to connect to Broker).

The broker has been started already with the same user id that execute the above command.

asked Dec 04 '09 at 17:09

Tuan's gravatar image

Tuan
21112

edited Dec 04 '09 at 17:46

Ville%20Laurikari's gravatar image

Ville Laurikari ♦
131129


The ssh-broker-ctl command should succeed if the connection broker is running in the default broker address.

In certain situations the broker will exit if it has nothing left to do. So, the first thing to check is the process listing to see if there is a ssh-broker-cli or ssh-broker-gui process there.

If a broker process is indeed running, check if the -a (or --broker-address) option was used when starting the broker. The -a option sets the local address (the name of a unix domain socket or named pipe) for the broker. If broker is using a non-default address, the same address must be supplied to ssh-broker-ctl using the -a option.

In your particular case, it appears that broker is using the address .broker-address-1, so this should work:

ssh-broker-ctl -a .broker-address-1

Note that on Unix platforms the broker address is a unix domain socket (a virtual file). You need to supply the full path to the unix domain socket if it's not in the current working directory.

link

answered Dec 04 '09 at 17:51

Ville%20Laurikari's gravatar image

Ville Laurikari ♦
131129

edited Dec 04 '09 at 19:03

Yes, there is already a broker process running

aaaa 23708 1591 0 11:26:38 pts/10 0:05 /opt/tectia/libexec/ssh-broker-cli -a .broker-address-1 --slave --no-gui

(Dec 04 '09 at 18:38) Tuan Tuan's gravatar image

A-ha! Your broker is using a non-default address (the -a option). I've updated my answer.

(Dec 04 '09 at 19:04) Ville Laurikari ♦ Ville%20Laurikari's gravatar image

If you're running broker in a non-standard place, you should set SSH_SECSH_BROKER in your environment to point to the broker address in question. In this case, export SSH_SECSH_BROKER="/path/to/.broker-address-1"

That way, all client applications (including ssh-broker-ctl) will find the broker.

(Dec 05 '09 at 12:42) Sami Lehtinen ♦ Sami%20Lehtinen's gravatar image
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×59
×27

Asked: Dec 04 '09 at 17:09

Seen: 15,288 times

Last updated: Dec 04 '09 at 19:03

All user contributed content licensed under the cc-by-sa license.
Powered by OSQA.