login about faq

Hello I get following error:

Error: Could not open connection to user@xx.xxx.xx.xx: Could not connect toxx.xxx.xx.xx: Key exchange failed

I am running following command.. sftpg3.exe -K D:\Path\PRIVATEKEY_rsa -B D:\sftp-commands.txt user@xx.xxx.xx.xx 1>D:\success.txt 2>D:\error.txt

I am running the above command as Windows task in Windows Server 2008. The task author is the machine account under which PRIVATEKEY_rsa was created. but in my task I have set to run it under Domain Service Account. And I get the above error.

If I run the command straight on the cmd line, no issues..It's only giving the error when I run it as windows task under domain service account. Thanks in advance for your help or suggestions.

asked Dec 06 '13 at 21:39

scarborough's gravatar image

scarborough
1111

I can't directly say what the problem is. It may be that you don't have the host key of the server host saved for the domain service account. In any case you will get much better error information if you try the same connection first with sshg3 and include the verbose mode flag: '-v'. The error reporting of sshg3 is much better then the one of sftpg3 and it is completely different.

(Dec 11 '13 at 13:57) Martin Dobsik ♦ Martin%20Dobsik's gravatar image
Be the first one to answer this question!
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×1

Asked: Dec 06 '13 at 21:39

Seen: 2,718 times

Last updated: Dec 11 '13 at 13:57

Related questions

All user contributed content licensed under the cc-by-sa license.
Powered by OSQA.