login about faq

Our server is windows 2008 R2. SSH server version is 6.3.4.24. The home directory of ftp user is set on NAS. When public key authentication is used, the SSH server generated error (2602) that HOME is not a directory. How to access the shared network folders?

asked Jan 30 '13 at 05:58

CityU%20HK's gravatar image

CityU HK
1113

edited Jan 30 '13 at 06:10


Hi CityU HK,

It seems that you may be experiencing the same issue which has been already described on this forum several times. See e.g. this question for answer:

SFTP with authorized keys to use Virtual Folders with AD authentication.

In the meantime the password cashing feature has been implemented. It is present in your version of a server 6.3.4. It should be enough to turn the password caching on and log in once with native windows password for every user that needs to access the network share. After that things should work with public keys as well.

If password cache is not an option for you then you have to follow the steps mentioned in the answers I mention above and hope all works well.

BTW: does your configuration work well if the home directory is set on a local drive?

I hope my answer can be useful.

With regards

Martin

link

answered Jan 30 '13 at 16:18

Martin%20Dobsik's gravatar image

Martin Dobsik ♦
599126

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×38

Asked: Jan 30 '13 at 05:58

Seen: 4,070 times

Last updated: Jan 30 '13 at 16:18

All user contributed content licensed under the cc-by-sa license.
Powered by OSQA.