login about faq

I have a Windows Server 2003 R2 Standard SP2 that hosts Tectia Server version

I am having a minor issue. When I setup a local user with a public key to access the SSH server, it ALWAYS goes to the default location after the successful login. I have tried setting up a specific service for it, but somehow Tectia server ignores it and always takes it to the default location. Is there any way I can fix this so that when a local user is logged in with a public key, they can go to the folder which they are meant to go to? It looks like ssh server is failing to recognize the local user and automtatically treat them as a user without the specific service defined.

asked Dec 22 '11 at 01:01

Tom's gravatar image


Ok. This is the solution I have found.

Go open the ssh-server-config file which is located under program filesssh communication securityssh tectiassh tectia server (program main folder)

Go to the line where it says '<domain-policy windows-domain-precedence="%local%,%default%...' Add in your local domain or your machine name (for an example edm-myserver-tx-1, so it will be like ------ '<domain-policy windows-domain-precedence="%local%,%default%, edm-myserver-tx-1, MGMDomain, XXX, YYY, ...'

Next, open up Tectia Server Configuration (GUI) then go to the service that contains local users as selectors. By default, it would look like '1 user name="localmachinenameuser" (note: there is a backward slash between localmachinename and user.) Change that to '1 user name="user"' without local machine name. Click on apply and hit OK.

Restart tectia server under services via administrative tools to restart the server with the new setting.

Try to connect to the server from a client machine and you will be able to go to the specific folder instead of the default folder.


answered Dec 22 '11 at 17:54

Tom's gravatar image


edited Dec 22 '11 at 17:57

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported



Asked: Dec 22 '11 at 01:01

Seen: 3,100 times

Last updated: Dec 22 '11 at 17:57

All user contributed content licensed under the cc-by-sa license.
Powered by OSQA.