login about faq

I need to be able to open SSH terminals via the command line on Win 7 using existing profiles

asked Jul 07 '11 at 22:22

scott_babineaux's gravatar image

scott_babineaux
1111


Hi Scott,

Please review (search for term - profile):

http://www.tectia.com/manuals/client-user/61/sshg3.html

sshg3 profile1

profile1 being the name of the profile in the ssh-broker-config.xml

Thanks, James Wright

link

answered Jul 08 '11 at 16:24

jamesw's gravatar image

jamesw ♦♦
468815

Thanks for the reply James,

I have read the docs and tried sshg3; here is what I get:

c:>sshg3 "v1 tsys proxy" sshg3: could not read license `C:Program Files (x86)SSH Communications Securit ySSH TectiaSSH Tectia AUXlicensesstc60.dat': Invalid syntax. Unable to connect to server.

Also, even though I have profiles setup I don't have a ssh-broker-config.xml. Just the example file.

(Jul 08 '11 at 16:38) scott_babineaux scott_babineaux's gravatar image

Hi,

It appears you have a 6.0 client license, however you are using 6.1.4 - they use different licenses. I suggest logging a support Tectia (either via your reseller, or direct at https://support.tectia.com/) and we can provide the correct license if there is a valid contract.

Thanks, James

(Jul 08 '11 at 16:42) jamesw ♦♦ jamesw's gravatar image

Actually I had both; I deleted the old license file and now get this:

c:>sshg3 "v1 tsys proxy" Unable to connect to server.

c:>sshg3 v1 tsys proxy Unable to connect to server.

Again; I don't have a ssh-broker-config.xml. Just the example file.

(Jul 08 '11 at 16:47) scott_babineaux scott_babineaux's gravatar image

Hi Scott,

If you search your machine, you should have two ssh-broker-config.xml.

%APPDATA%\SSH\ssh-broker-config.xml: the user-specific Connection Broker configuration file

For example:

C:\Users\jamesw\Application Data\SSH\ssh-broker-config.xml

From the command you are using, I assume you have setup public key authentication?

Thanks! James

(Jul 08 '11 at 16:55) jamesw ♦♦ jamesw's gravatar image

doh, I found it; looking in the wrong place. I am using user/password auth for some and keys for others.

(Jul 08 '11 at 16:57) scott_babineaux scott_babineaux's gravatar image

Hi,

Can you try the command with a profile with public key setup? I am testing currently, and not having any issues (I am using client 6.1.9:

sshg3 test1test sshg3 winxptestserver

Thanks, James

(Jul 08 '11 at 17:01) jamesw ♦♦ jamesw's gravatar image

I'll have to get the keys gen'd and put in place. Nominally I use user/password. Can you explain the syntax you are using above?

(Jul 08 '11 at 17:04) scott_babineaux scott_babineaux's gravatar image

Hi,

Syntax didn't come across correctly:

Should be:

Test 1:

sshg3 test1test

Test 2:

sshg3 winxptestserver

Thanks, James

(Jul 08 '11 at 17:07) jamesw ♦♦ jamesw's gravatar image

Fails with keys as well.

c:>sshg3 postman Unable to connect to server.

(Jul 08 '11 at 17:16) scott_babineaux scott_babineaux's gravatar image
showing 5 of 9 show all
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×55
×4
×2

Asked: Jul 07 '11 at 22:22

Seen: 4,845 times

Last updated: Jul 08 '11 at 23:37

All user contributed content licensed under the cc-by-sa license.
Powered by OSQA.