login about faq


I am having an issue with a Script that is using SSH

ls -lrt script.sh -rwxr-xr-x 1 user01 group001 1358 Apr 13 13:56 script.sh

The section I am having trouble with is below.

=== script.sh ===

/usr/local/bin/ssh -B winuser@windowsServer001 E:\mybatchfile.bat

=== script.sh ===

When I run the script as user01 it runs fine.

However if as user02 I Run:

sudo -H -u user01 /home/user01/script.sh

I get the following SSH error:

No such file or directory

Connection error: Unable to connect to Broker

Any Ideas on what is wrong?

asked Apr 13 '11 at 16:00

grahambo's gravatar image


edited Apr 13 '11 at 22:34

Roman's gravatar image

Roman ♦♦

Hi, Does it work for user02 if you run it without sudo? Also what Tectia and OS versions are you using?

(Apr 13 '11 at 22:33) Roman ♦♦ Roman's gravatar image


If you run the script as user02, i.e:

ssh -B winuser@windowsServer001 E:mybatchfile.bat

What results do you get?

Thanks, James

(Jun 21 '11 at 15:32) jamesw jamesw's gravatar image
Be the first one to answer this question!
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported



Asked: Apr 13 '11 at 16:00

Seen: 7,410 times

Last updated: Jun 21 '11 at 15:32

All user contributed content licensed under the cc-by-sa license.
Powered by OSQA.