login about faq

I have two Windows Server 2003 R2 Standard SP2 hosts, running on VMWare. virtual001 is running SSH Tectia Server version virtual002 is running SSH Tectia Server version

I'm trying to set up key-pair authorisation to two local users on these machines. I've created a key pair using OpenSSH, because of a restriction on the Java tool the operates at the client end, and have converted the public key to Tectia format.

The public keys have been placed in the location specified in the config file, which happens to be D:\SSH_PUBLIC_KEYS\%U. Only public-key authentication is enabled and only the two local users are allowed to authenticate.

Authentication was attempted from the command line of an AIX server using:
ssh user1@virtual001
ssh user1@virtual002

On virtual002, everything works perfectly. On virtual001, authentication fails - the pertinent error message from the event logs appears to be:
708 Publickey_auth_error, Username: user1, Algorithm: publickey, "Could not find the received public key in user's public key authorization file or directory", Session-Id: 1

I've compared the config files for the two machines - they only differ in hostnames, ip-address (for the listener) and the setting windows-terminal-mode on virtual001. I've compared the key locations, and the keys are present and identical. On virtual001, I've also copied the key to C:\Documents and Settings\user1\.ssh2\authorized_keys as a precaution.

I've tried enabling Troubleshooting mode on the SSH Tectia Server on virtual001, but it doesn't appear to work in any meaningful way - in fact, the only thing is appears to do is slow the server down by a factor proportional to the level selected. No logs are produced at any time. All my information is coming from the event logs.

I tried running the connect command on the AIX client using the -v option and got this:
adam@unix001:(no_env):/users/adam $ ssh -v virtual001\user1@virtual001
Disconnect reason code: 14 (local disconnect)
Disconnect description: Authentication failed
Server authentication: publickey
User authentications completed: none
Failed user authentications: publickey[#9]
Server identity: 1536 bit rsa key
SHA-1: 3bc677a6a44f9016bdfbada4e38062febdeff1c1
Request exec channel error: Authentication failed.

I tried returning everything on virtual001 to default and attempted a login using password authentication. It basically failed three times: the same key failure as above, followed by three instances of
714 Password_auth_error, Username: hyperion, Algorithm: password, "Password not valid UTF-8.", Session-Id: 1
followed by three instances of
723 Keyboard_interactive_password_auth_error, Username: hyperion, Algorithm: password, "Authentication failed for user `IISDGVIRTUAL096\hyperion'.", Session-Id: 1

Any ideas?

Thanks in advance - Adam Cheney.

asked Mar 17 '11 at 13:53

Adam%201's gravatar image

Adam 1

edited Sep 21 '11 at 17:27

SSH%20KB's gravatar image


Be the first one to answer this question!
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported



Asked: Mar 17 '11 at 13:53

Seen: 13,781 times

Last updated: Sep 21 '11 at 17:27

All user contributed content licensed under the cc-by-sa license.
Powered by OSQA.