login about faq

SSH Version: Tectia Client 6.3.8 on x86_64 OS Version: Red Hat Enterprise Linux Server release 6.6

Here is my issue. I'm create a private and public key on Server A and copied those keys over to Server B. I want to be able to ssh from server A to server B without being prompted for a password. Once I copied the keys over to Server B I tried to ssh from server A to server B. That failed. And when I mean failed in this question I mean failed that it prompted me for a password on server B. I was ssh from server A to server B from a regular account and not using root. as a matter of fact everything I do with be from the regular account and not from root. So I ran sp -ef and see that the ssh-broker-g3 daemon is running. So after doing a little digging I ran the command "ssh-broker-ctl add-key <path-to-private key="">". Then I ran the command "ssh-broker-ctl list-keys" and I see the private key. (I didn't see that the first time I ran that command. Nothing showed up) I ran a quick test and was able to ssh to server B from server A without being prompted for a password. :) Great. So I broke the connection. Then I tried it again and it failed. I ran the list-keys command again and the key was gone. I added it back with the add-key command. I ran the list-key command again it was there. I waited 1 minute and ran the list-key command and the key was gone. Now here is something interesting. So I added the key again and this time I ran the command "watch ssh-broker-ctl list-keys" in another window to see when the key was disappearing. The key never disappeared. I ran the list-key command 1,5,10 minutes apart and the key was still there. But when I breakout of the watch command in the other window, the key disappeared. So in order for this to work right now I have to add the key with the add-key command, start up the watch command in another window and let that run so that ssh will work. I am needing this work on a smaller scale so that I can move it to a bigger scale. I am sure that this is not the way it suppose to work. can you help me out with this or at least point me in the right direction. I did see this while doing some research on this problem:

Bug Fixes in 6.3.8 - All platforms: Fixed a problem that caused Tectia Client applications (e.g. sshg3/sftpg3/scpg3) to fail intermittently when ssh-broker-g3 was used in the run-on-demand mode.

But as you can see, we have this version of tectia.

This question is marked "community wiki".

asked Jul 08 '15 at 02:46

tjbillups's gravatar image


Be the first one to answer this question!
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported



Asked: Jul 08 '15 at 02:46

Seen: 7,923 times

Last updated: Jul 08 '15 at 02:46

All user contributed content licensed under the cc-by-sa license.
Powered by OSQA.