login about faq

sending files from windows 2012 server to linux server using tectia client and windows scheduler.

This process was working until 3 weeks ago using the windows scheduler. now it only works using the command line.

This is the sftp command in the batch file.

sftpg3.exe -P 922 -B c:\jobs\bhpb.bat username@hostname 1>>c:\jobs\log\SFTPTransfer.log 2>>c:\jobs\FailAlert\alert.txt

Here is the error in the alert.txt Error: Could not connect to broker: OpenProcess failed: 5 / Failed to get process 9712 integrity level. / Trustworthiness of the client process cannot be verified. Refusing to serve unknown client. / Broker is already running. / Failed to start on-demand Broker.

Here is the error in the SFTPTransfer.log Error Code 4

Is there anything that can fix this issue.

asked Jan 29 '15 at 22:59

Shahin's gravatar image


I'm having the exact same problem

Windows service runs sftpg3 with a -B batchFile <profilename> arguments.

When run from command prompt, works perfectly. When run via the service (which is running under the same credentials as when I'm logged into the system), then I get errors described above.

Would love to know how to solve this issue.

(Mar 23 '15 at 17:36) philipsDev philipsDev's gravatar image

Have you tried to run Tectia Broker in daemon mode? You can start daemon with command "ssh-broker-ctl start".

(Mar 23 '15 at 22:17) Fraction Fraction's gravatar image


I think I have probably seen this same, but with SCPg3. Sometimes my scheduled tasks (and I have quite lot of those) just fails with error code 4 and error msg: "error: could not connect to: `Profile_name' , and they will fail until I run it once from cmd.. and same time other tasks (which also uses SCPg3, even with the same profile) are running totally okay.

I have never found any proper solution for this, so I also really appreciate, if someone can give some guidance/hints with this..


answered Feb 17 '15 at 19:47

Fraction's gravatar image


edited Feb 17 '15 at 19:49

One question to Shahin, Are you running Tectia Connection Broker in daemon, or in "on demand" mode? You can check it from cmd with command "ssh-broker-ctl status" ?

I just realized, that I haven't seen this since this: Broker running since Thu Jan 29 2015 23:14:02 +0200 [up 17 days 18:11:51]

..but then I rebooted my server on monday, and now problem is back. I think it somehow combined with fact, that after reboot my broker was again in "on demand" -mode and it also seems that if I start it in daemon mode (using cmd + run as different user) it stops again quite soon I close the cmd prompt of my transfer-user.

Is there any to way to force it stay up, regardless of login-status of user? I'm running tasks with normal user account made only to that purpose.

Any help with this, anyone?


answered Feb 18 '15 at 09:23

Fraction's gravatar image


Try putting the stopping and restarting the broker in the batch file your calling before the sftp command.

At first glance this may appear as intermittent because if your logged into the user will be logged in (interactively) as the user that’s running the job and therefor the broker is already up and running.

The problem usually is the UAC (User Account Control). When you are an admin on new Windows computer (Vista and newer) and UAC is on, you have 2 identities and they do not trust one another. So the problem probably is that ssh-broker-g3.exe process has been started when you normally logged in to the machine. It has been started without elevated privileges. But when a service is started in Session 0, it starts all processes WITH elevated privileges. So now the connection broker (ssh-broker-g3), does not have rights to send communication handles to sftpg3 process.

You can easily fix this either:

By first stopping the ssh-broker-g3 process and starting it again with elevated privileges. Or by by stopping the process and making sure no one else will start it. In that case sftpg3 will start it itself; when it needs it with correct UAC level.


answered Sep 11 '15 at 14:42

Joe%20-%20Tectia%20Support's gravatar image

Joe - Tectia Support ♦♦

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported



Asked: Jan 29 '15 at 22:59

Seen: 15,174 times

Last updated: Sep 11 '15 at 14:42

All user contributed content licensed under the cc-by-sa license.
Powered by OSQA.