login about faq

I am trying to use the Tectia sftpg3 command line utility on a UNIX client to connect to a server, but the username includes the "@" symbol because the domain has to be specified. With the generic sftp utility I can accomplish this using the syntax "sftp -o user=username@domain servername", but the Tectia client doesn't have that option and it tries to interpret everything after the first "@" symbol as the server name.

I have tried:

sftpg3 username@domain@servername
sftpg3 username\@domain@servername
sftpg3 username/domain@servername
sftpg3 username\\domain@servername
sftpg3 'username@domain'@servername

SSH key authentication isn't an option so I can't bypass it that way.

asked Mar 15 '13 at 15:48

kupacmac's gravatar image

kupacmac
1112

edited Mar 15 '13 at 15:49


link

answered Jul 20 at 07:50

pseudoblue's gravatar image

pseudoblue
1

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×3

Asked: Mar 15 '13 at 15:48

Seen: 2,801 times

Last updated: Jul 20 at 07:50

All user contributed content licensed under the cc-by-sa license.
Powered by OSQA.