login about faq

scp Fails for root with the below message:

"Executing ssh1 in compatibility mode failed (Check that scp1-compat-srv/scp is in your PATH). lost connection"

command used: "scp filename dest_server:/dest_dir"

SCP with non-root id works fine. ssh works fine for both, root n non-root id.

RSA keys are generated and shared for password-less login and filetransfer.

Could you please let me know how to fix this.


Server: scp -V scp: SSH Tectia Client 6.0.12 on sparc-sun-solaris2.8

Client: Sun_SSH_1.1.1, SSH protocols 1.5/2.0, OpenSSL 0x0090700f

asked Sep 15 '10 at 14:02

Prashant's gravatar image


Found the issue. The public key generated had the below line. Removed the same and tried scp,ssh both works fine.

command="eval $SSH_ORIGINAL_COMMAND",from="client_ip_address"


answered Sep 15 '10 at 22:49

Prashant's gravatar image


Ok. good to know you figured it out. And thanks for posting what the solution was. Remember to accept your own answer (by clicking on the arrow to the left of the question) so that we know this question was answered.

Regarding the command keyword, this is used to restrict the usage of the public key for a particular purpose. In this case to run a particular command. See http://oreilly.com/catalog/sshtdg/chapter/ch11.html

(Sep 16 '10 at 08:40) Roman ♦♦ Roman's gravatar image

Is there a ssh user config for root (probably under $HOME/.ssh/config) ? In case there is, does it work if you move it so that the default config is used?

Based on what you describe it looks as if it's trying to connect to Tectia Server using the SSH1 protocol, which is not supported by Tectia Server (only supports the SSH2 protocol since SSH1 is unsafe).

But it's strange that scp would work for other users and not for root, unless there was a specific user config for root which differs from the global one.


answered Sep 15 '10 at 14:34

Roman's gravatar image

Roman ♦♦

Thanks Roman. Me too checked regarding the SSH1 and SSH2. But what confused me that it was working for non-root id. Another thing which I just noticed was root is allowed access via public key auth, while others interactive. When I change access to root via interactive, it works.

So, need to figure out whats different and preventing using public key auth.

Let me know if you think of any.


(Sep 15 '10 at 15:16) Prashant Prashant's gravatar image

Have you tried browsing through the Tectia server logs (on syslog)? Any pointers there as to why the connection for root is failing?

(Sep 15 '10 at 18:51) Roman ♦♦ Roman's gravatar image
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported



Asked: Sep 15 '10 at 14:02

Seen: 9,059 times

Last updated: Sep 15 '10 at 22:49

All user contributed content licensed under the cc-by-sa license.
Powered by OSQA.